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Anchor-Animation Relationships 

To quickly create animations in IronCAD, it is extremely important to understand the 
relationship between animations and an objects 'anchor' . The anchor has many functions 
in IronCAD, one of which is providing a reference point for animations. Every Group, 
Model, and Shape in IronCAD has an anchor, and is visible only when that object is 
selected. It looks like a yellow "L" shape, with a red dot at the joint. The long part of the 
"L" is the object's Height  axis. The short part of the "L" is the Length axis. The axis not 
indicated by the anchor is the Width axis (shown as a dotted line below). 
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For instance if a 'Height Move' from the Animation catalog was dropped onto this cylinder, 
it would move a certain distance upward, along the Height axis of the anchor. Similarly, if a 
"Width Spin" were dropped onto the cylinder instead, it would rotate about the Width axis 
of the anchor using the anchor as the center of rotation, or 'pivot' point. 

In many cases it is necessary or useful to reposition the anchor to control the animation 
behavior of an object. For example, consider the model shown in the image below. If point 
A is the initial position of the model's anchor and a "Height Spin" is applied, the model will 
rotate about axis A, using the default anchor location (point A) as a pivot point. If the 
desired effect is that the model rotate about a different point/axis on the model, let's say B, 
then the easiest way to achieve this is by moving the anchor location. If the anchor can be 
relocated to point B then the desired effect will be achieved and the animation itself does 
not have to be modified. 
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There are three ways to relocate the anchor relative to it's parent object: 

1. Use the Move Anchor tool. This method is most useful when moving the anchor to 
another location on the SURFACE of the model. To use the Move Anchor tool, first select 
the model and then choose Move Anchor from the Shape menu. The cursor changes to an 
anchor icon and SmartSnap feedback is activated as the cursor is moved over the model. 
Now click on a new location for the anchor. 

2. Use the TriBall. This method is useful when moving the anchor to a location which is 
not on the surface of the model and/or the precise location is not important. To use the 
TriBall, first select the object, then select the objects anchor by clicking directly on it (the 
center of the anchor turns yellow and the axes extend slightly). Turn on the TriBall and use 
it normally to relocate the anchor. 

3. Use the Anchor property sheet. This can be useful when exact distances or angles are 
known. Access this by right clicking the object and choosing Properties. Then choose the 
Anchor tab and enter the appropriate values. 

Page 3 of 14

7/11/2002file://C:\Documents%20and%20Settings\clohman\My%20Documents\tutorials\animation\index.html...



   

Creating an exploded parts animation  

Once the relationship between anchors and animations is understood, exploded part 
animations can easily be created in IronCAD by using simple drag and drop 'Move' 
animations from the Animations catalog. For example, consider the part shown below. 

By noting the position of each part's anchor, it is easy to determine what type of animation 
should be used on each part (see image below): a Height Move for parts A and C, and 
Length Move for part B. Part D doesn't require an animation since all of the other parts are 
moving away from it. 
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Adjusting Timing with the SmartMotion Editor  

These animations provide correct paths for the parts, however they do not account for any 
interference between parts during the 'disassembly' process. Upon examination is apparent 
that part C cannot move until part B is moved. Furthermore, part B cannot be moved until 
part A is moved. 

To change the 'timing' of these animations, the SmartMotion editor must be used. The 
SmartMotion editor is a feature of IronCAD that allows the detailed editing of animation 
keyframes and sequencing. To access it, choose SmartMotion editor from the View menu. 
Then the SmartMotions can be arranged with the correct timing as shown below.  
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Modifying a SmartMotion  

Sometimes, depending on the model or group size and orientation, the default catalog 
'Move' animations may be much too short, too long, or in the opposite direction. However 
it's easy to modify these animation paths after they have been applied. There are four 
primary ways to do this: 

1. The TriBall  

The easiest and most visually intuitive way to modify the animation path is by using the 
TriBall. To do this, select model whose path you want to modify. The path should appear as 
a white line or curve. Now select the white animation path. The animation path grid will 
appear, showing the key frame points in red. Select the red key frame point at the end of the 
path and turn on the TriBall. Use the TriBall normally to adjust the final position of the 
model. Then turn off the TriBall and select the background of the scene to deselect the 
animation & model. 
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2. Dragging key frame points  

Another way to modify an animation is to simply click and drag the red key frame points on 
the animation path. This will slide the key frame points around on the 2D animation grid. 
To change the position in the height direction, use the red square handle that appears above 
the key frame point when it is selected. 

3. Key frame properties  

Yet another way to modify the animation path is by directly editing the key frames 
numerically via the Key Frame Property sheet. This can be accessed by right clicking on 
any red key frame on the animation path. 

4. SmartMotion Editor  

Still another way to modify the animation path is by directly editing the SmartMotion key 
frames numerically via the SmartMotion Editor. To do this, select SmartMotion editor from 
the View menu, double click on the bar with Model name of interest. This will expand the 
bar to show any SmartMotions that have been applied to the model. Right click on the 
SmartMotion of interest and select Properties, then choose the Path tab. Now change the 
Current Key to the desired number, then click Key Setup. Enter the new position/orientation 
values. 
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Creating animations for general viewing  

Many times the only purpose of generating an animation is to simply show all viewpoints of 
a design clearly and quickly. IronCAD allows you to create these types of animations in just 
a few operations by utilizing pre-calculated SmartMotions from the Animations catalog. 

One technique for creating an animation for general visualization purposes is to use the 
'Spin' animations as described below. 

1. Choose Fit Scene on the Camera toolbar.    

2. If there are multiple models in the scene which are not grouped, group them now by 
choosing Select All from the Edit menu, then click the Group button on the Editing toolbar. 

  

3. Drop the three 'Spin' animations onto the Model / Group    

4. In the SmartMotion editor, adjust the animations so that they occur sequentially as shown 
below. The order is not important. 

5. Play the animation. If the model / group spins out of the view port, the anchor may need 
to be repositioned nearer to the center of the model / group. 

6. Export the animation. Choose Export Animation from the File menu. 
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Creating a Dynamic Cutaway animation  

A Dynamic Cutaway is useful application which utilizes IronCAD 'negative' IntelliShape 
and Animation technology. A Dynamic Cutaway can be described as 'moving cross-section'. 
In order to create this type of animation, the design must be a solid model (i.e. native 
Intellishapes or imported SAT//IGES solid/STEP file. In order to create a Dynamic 
Cutaway animation use the following procedure: 

1. Drop the 'H Block'  onto a surface on the model which is perpendicular to the 
direction of the desired cutway direction. 

2. Resize the block so that it cuts away the appropriate size cross-section. In general, it 
should be larger than the entire model, especially in the direction of the cutaway. 

3. Drop a 'Height Move' animation   from the catalog onto a surface that the H Block 
is cutting. The animation path will appear. 

4. Modify the path so that the block will move through the entire part (as previously 
described, a number of techniques are available to modify the SmartMotion). 
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5. Play back the animation using the SmartMotion toolbar. Preview the animation to insure 
that the model is able to 'regenerate' at each frame. In some cases the geometry may be too 
complex to perform the cutaway at all points. 

6. Export the animation. 

  

Exporting Animations  
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There are two main categories of animation export types: 

Single file, or 'Encapsulated' (AVI and Animated GIF) 

Multiple frame files (BMP, TGA, TIF, JPG, etc...) 

As with rendering, the best settings for exporting animations depend greatly on the intended 
use. The table below gives some recommended export settings for different applications: 

  

*to set the frame rate, right click on the background of the SmartMotion Editor and choose 
Properties, then type in the appropriate frame rate. The total number of frames will be 
increased/decreased appropriately. 

  

Animation compression and color depth  

AVI 

AVI is a compressed video format which allows real time playback of video/animation via a 
computer. IronCAD allows the AVI image 'quality' to be specified when the animation is 
exported. This 'quality' setting is inversely related to the level of compression. In other 
words, higher quality settings will result in a larger AVI file size than lower quality settings. 
However, because AVI is a compressed format by design, even the 'highest quality' setting 
will result in some loss of image quality. Because of the nature of the AVI compression 
scheme, this loss of quality will be most apparent in animations which contain very subtle 
color changes, such as 'gradient' backgrounds and textures. 

INTENDED 
USE

FILE 
TYPE

SUGGESTED  

RESOLUTION 

FRAME 
RATE*

ADVANCED 
OPTIONS

Web 
Publishing

Animated 
GIF

100x75 pixels  

(DPI unimportant) 

5 fps - minimize 
storage

General 
Viewing on PC 
(e.g. 
embedding 
into MS Word 
or PowerPoint)

AVI 320x200 pixels  

(DPI unimportant) 

15 fps (default 
frame rate)

-Highest 
Quality  

-24 bit color 

Video (e.g. 
VHS 
videotape)

TGA 720x480 pixels  

(DPI unimportant) 

24-30 fps -24 bit color
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Similarly, the 24-bit color option will produce a larger file size but will also have much 
higher image quality when viewed on displays in 16 to 24 bit color. The 24-bit option is 
recommended for most cases, unless file size is an extremely critical issue. 

Animated GIF 

GIF is also a compressed animation format, and was developed for transferring graphics 
'online'. Traditionally the GIF format is used to store single image files, but beginning with 
GIF version 89a the format is also used store animations, or 'flipbooks' of GIF images in 
sequence. This is currently the most popular format for animations on the Web and is 
supported by all newer browsers. 

The GIF format has a maximum color depth of 256 colors (8 bit) and animations exported 
from IronCAD in this format have small file size, but can appear somewhat 'grainy' when 
played back. One reason for this is that IronCAD does not 'optimize the color palette' of the 
GIF file for each animation, but rather uses a standard 256 color palette. Although it 
involves the use of additional software, the following technique can be used to create a 
higher quality GIF animation: 

- Export the animation as multiple 24-bit color image files (from the file menu, choose 
Export Animation and choose a format other than GIF or AVI, such as TIF, TGA, BMP). 

- Use an image conversion / processing program (PaintShop Pro, Image Composer, 
PhotoShop) to convert the files to a series of GIF images, using any color palette 
optimization settings available. 

- Use a program such as 

Microsoft GIF Animator - 
http://www.microsoft.com/imagecomposer/gifanimator/gifanin.htm 

or GIF Construction Set - http://www.mindworkshop.com/alchemy/gifcon.html 

to compile the individual GIF files into a single animated GIF file. 
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