Drawing templates



Opening an Existing Drawing Template

Creating a Drawing from a DXF or DWG Template

Saving a User-Defined Drawing Environment as a Template


When a new drawing is created, the user is first prompted to select a pre-defined drawing template.  Several standards-based templates of varying sizes provide paper space onto which views can be placed.  These templates can be used "as is" or as starting points for creating custom templates.


Drawing templates are a key component of the drawing system.  They specify styles and layers available for such items as lines and hatched regions, in addition to specifying default properties for the current drawing elements.


Included are several predefined drawing templates conforming to ANSI English, ANSI Metric, and ISO drawing border standards.  However, these templates contain only a minimum of defined named styles.  If desired, you can specify an existing template to be used as a default each time a new drawing is created, or you can define a custom drawing environment and save it as a new template for later access. Note: You can import styles & layers from existing templates by using Import Styles and Layers under the File pull-down menu.


Opening an existing drawing template

When creating a new template, it is best to begin with one of the predefined templates, as follows:

  1.  From the File menu, select New and then Drawing from the resulting dialog box.  The New Drawing properties sheets opens to the Workspace (English) templates.

  2. Select a template and then select OK.

  3. An empty drawing sheet is displayed.

Or, if desired, you may create a new drawing using an existing .dxf/.dwg template.


To create a drawing using an existing .dxf/.dwg template

  1. From the Tools menu, select Options.

  2. Select the AutoCAD Import tab.

    The properties sheet is displayed with the following options:

    • Default Length Units.  AutoCAD R13 files do not contain any unit information.  AutoCAD R14 files only specify either Metric or English unit, not the specific measurement unit.  However, the software must be informed of the data unit that is being imported in order to properly convert the file.  From this field’s drop-down list, select the length unit to be used as the default type for unitless files.  The options are:

      • Centimeters

      • Feet

      • Inches

      • Meters

      • Millimeters

      • Yards

    • TrueType Font File Directories.  In this field, enter the directory to be searched for TrueType font files during translation.  The Windows font directory is the default location.

    • SHX Font Map.  This list displays the current SHX font map.

      • Add.  Use this option to access the Add SHX Font Map Entry dialog box, specify SHX and TrueType font names, and select OK to add the new SHX font map to the displayed list.

      • Remove.  Use this option to remove the currently selected SHX font map from the displayed list.

    • Sheet Size Selection.  (If graphics extents do not fit drawing limits)  An AutoCAD drawing specifies two sets of limits:  Drawing limits (equivalent to page size) and graphics extents (the overall bounding box of the graphics).  By default, AutoCAD allows you to create graphics outside the drawing limits unless the user specifies that it should not.  Therefore, it is possible for the overall bounding box of the graphics to exceed the drawing limits in length and/or width.  This option allows the user to specify the size of the sheet in this situation.

    • Size sheet to drawing limits.  Select this option to size the sheet based on the drawing limits.  If selected, the graphics may lie partially or completely outside the sheet.

    • Use standard size closest to extents.  Select this option to specify creation of a sheet of the smallest standard size that fully encloses the bounding box.  The standard sizes used for comparison will be chosen according to the units of the imported AutoCAD file.  If a standard size is found, the graphics will be centered on the sheet and orientation (Landscape or Portrait) will be set to the option that best fits the graphics.  If a standard size is not found, a custom-sized sheet that encloses the graphics will be created.

    • Use custom size to enclose extents.  Select this option to specify creation of a custom-sized sheet that encloses the graphics.

  3. Define the AutoCAD import options for the .dxf/.dwg template to be used for the drawing and then select OK.

  4. From the File menu, select Open.

     An alternate method of accessing a drawing template file is by selecting the Open an existing Scene or Drawing option on the Welcome dialog box displayed on product startup.

  5. From the Files of type drop-down list, select either the appropriate AutoCAD extension or All Files.

  6. Browse to locate and then select the desired template file to be used for the drawing and select OK.

  7. Select OK on any dialog boxes that may be displayed.

A progress indicator is displayed during the import process that indicates the percentage of import completion, the number of entities processed, and the total number of entities in the file.  If necessary, the import process can be interrupted by hitting the Escape key.  A message box will be displayed asking the user to confirm or cancel the Abort command.  If the command is confirmed, translation will be aborted and the graphics created up to that point will be displayed.

If the import process is not aborted, a new drawing will be created using the selected drawing template.


NOTE:  When a .dxf/.dwg template file is opened, it always creates a new drawing, regardless of whether or not a drawing is currently open.


If you choose not to use a predefined template or an existing AutoCAD drawing border, you can create a custom template.  Begin with a blank sheet of paper by selecting New from the File menu, Drawing, and then opening the Blank Drawing template.


To save a user-defined drawing environment as a drawing template

  1. With the drawing environment to be saved as a template active, from the File menu, select:

      • Save, if the active drawing has not been previously saved, or

      • Save As, if the active drawing has been previously saved.

  2. From the Save As type pull-down menu, select Template Files (.icd).  (Note that this is the same file extension used for Drawing Files.)

    The Save in: directory automatically changes to the default template directory, which contains all Workspaces (Under Drawing Templates/Folders) templates.  If desired, you can change this location.

  3. Enter a file name for your new drawing template and then select Save.\

    The new custom drawing template can now be accessed from the File menu, by selecting New and then Drawing from the resulting dialog box.  If the default location was retained in the previous step, the new template is included on the Workspaces tab displayed by default.